Home > QoS Questions

QoS Questions

October 16th, 2010 in CCIE Written Go to comments

Here you will find answers to QoS Questions

Question 1

Which of these is a valid differentiated services PHB?

A. Guaranteed PHB
B. Class-Selector PHB
C. Reserved Forwarding PHB
D. Discard Eligible PHB
E. Priority PHB


Answer: B

Question 2

Refer to the exhibit. When applying this hierarchical policy map on the on the tunned interface, you measure high jitter for traffic going through class 1234. What is the most likely cause of this jitter?

class-map match-all 1234
  match ip precedence 5
class-map match-all 5555
  match access-group 105
class-map match-all 5554
  match access-group 104

policy-map tun-shap
 class class-default
   shape average 150000 300000
   service-policy mark

policy-map mark
 class 1234
  priority 64
 class 5555
  set dscp af31
  bandwidth remaining percent 50
  random-detect  dscp-based
 class 5554
  set dscp af32
  bandwidth remaining percent 25
  random-detect dscp-based
interface Tunnel 1
 ip address 20.2.2.1  255.255.255.252
 ip load-sharing per-packet
 load-interval 30
 qos pre-classify
 tunnel source 4.4.4.1
 tunnel destination 4.4.4.2
 service-policy output tun-shap

access-list 104 permit ip any host  5.5.5.4
access-list 105 permit ip any host 5.5.5.5

A. The configuration of a hierarchical policy map on a tunnel interface is not supported.
B. Class 5555 and class 5554 are both taking up 100% of the bandwidth, leaving nothing for class 1234.
C. The burst size for the traffic shaping is wrongly configured to 15000; this would require an interface capable of sending at 150Mb/s.
D. The burst size for the traffic shaping has been wrongly configured; it should be set as low as possible.
E. The burst size for the traffic shaping has been wrongly configured; it should be set as high as possible.


Answer: D

Question 3

Refer to the exhibit. When applying this policy map on the tunnel1 interface, you see packet loss for the TCP class starting at around 100000 b/s, instead of the configured 150000 b/s. What is the most likely cause of the discrepancy?

class-map match-any tcp
 match protocol http
 match protocol ftp
class-map match-all acl180
 match access-group 180

policy-map police
 class tcp
    police 150000 1000 conform-action transmit exceed-action drop
 class acl180
    police 150000 conform-action set-prec-transmit 2 exceed-action set-prec-transmit 1 violate-action set-prec-transmit 0

interface Tunnel1
 ip address 20.1.1.2 255.255.255.252
 service-policy input police
 load-interval 30
 tunnel-source 4.4.4.2
 tunnel destination 4.4.4.1

A. The violate-action command should not be configured.
B. The current configuration of the load-interval command on the tunnel interface is preventing proper policing calculations.
C. The burst size is too low.
D. Policing on tunnel interfaces is not supported.
E. The CIR keyword is missing in the policer.


Answer: C

Question 4

Refer to the exhibit. As a network administrator, you have configured a dual-rate, dual- bucket policer in accordance with RFC 2698 on the serial interface of you router, connecting to your provider. The SLA with your provider states that you should only send AF31 (limited to 150 kb/s), AF32 (limited to 50 kb/s)and AF33 (best effort). Your service provider claims you are not conforming to the SLA Which two things are wrong with this configuration? (Choose two.)

class-map match-all af31
 match dscp af31
class-map match-all af32
 match dscp af32
class-map match-all af33
 match dscp af33

policy-map marking
 class af31
  set dscp af31
 class af32
  set dscp af32
 class af33
  set dscp af33

policy-map limit
 class af33
  police cir 150000 bc 50000 pir 200000 be 50000
   conform-action set-dscp-transmit af31
   exceed-action set-dscp-transmit af32
   violate-action set-dscp-transmit default
 class class-default
 bandwidth 300

interface Ethernet0/1
 ip address 3.3.3.1 255.255.255.0
 no ip proxy-arp
 load-interval 30
 half-duplex
 no keepalive
 no cdp enable
 service-policy input marking

interface serial0/0
 ip address 4.4.4.1 255.255.255.252
 ip load-sharing per-packet
 encapsulation ppp
 load-interval 30
 no dce-terminal-timing-enable
 service-policy output limit

A. The configuration of a service policy on half-duplex Ethernet interfaces is not supported.
B. The class class-default sub-command of the policy-map limit command should be set to the DSCP default.
C. The violate action is wrong.
D. This policer configuration is not implementing RFC 2698 dual-bucket, dual-rate.
E. The policer is configured in the wrong class


Answer: C E

Question 5

Refer to the exhibit. You have noticed that several users in the network are consuming a great deal of bandwidth for the peer-to-peer application Kazaa2. You would like to limit this traffic, and at the same time provide a guaranteed 100 kb/s bandwidth for one of your servers. After applying the configuration in the exhibit, you notice no change in the bandwidth utilization on the serial link; it is still heavily oversubscribing the interface.
What is the cause of this problem?

no ip cef
class-map match-all kazza2
 match protocol kazza2
 class-map match-all server
 match access-group 105

policy-map p2p
 class kazaa2
 drop
 class server
 bandwidth 100
 class class-default

fair-queue

interface Serial0/0
 bandwidth 1234
 ip address 20.1.34.1 255.255.255.252
 ip load-sharing per-packet
 encapsulation ppp
 load-interval 30
 no dce-terminal-timing-enable
 service-policy output p2p 

A. CEF needs to be enabled for NBAR.
B. In class Kazaa2, you should configure a policer instead of a drop command.
C. The server class should have a priority of 100. 
D. The bandwidth parameter on serial 0/0 is wrong.
E. Kazaa2 is not a valid protocol.


Answer: A

Question 6

All of these are fundamental building blocks of a differentiated senvices Traffic Conditioner Block except which one?
A. dropper
B. classifier
C. marker
D. querier
E. meter
F. shaper


Answer: D

Question 7

Refer to the exhibit. You would like to guarantee 7 Mb/s for FTP traffic in your LAN, as it seems that peer-to-peer traffic is taking up a large amount of bandwidth. When testing the configuration, you notice that FTP traffic doesn’t reach 7 Mb/s. What is the problem?

ip cef  

class-map match-all ftp
 match protocol ftp
class-map match-all voice
 match precedence 5  

policy-map mark
 class voice
 priority 200
class ftp
 set dscp af32
 bandwidth 7000
 random-detect
 dscp-based
class class-default  

interface Tunnel1
 ip address 20.1.1.1 255.255.255.252
 load-interval 30
 qos pre-classify
 tunnel source 4.4.4.1
 tunnel destination 4.4.4.2
!
interface Tunnel2
 ip address 20.2.2.1 255.255.255.252
 load-interval 30
 qos pre-classify
 tunnel source 4.4.4.1
 tunnel destination 4.4.4.2  

interface Ethernet0/1
 ip address 4.4.4.1 255.255.255.0
 no ip proxy-arp
 load-interval 30
 half-duplex
 no keepalive
 no cdp enable
 service-policy output mark 

A. The Ethernet interface should have keepalives enabled.
B. The duplex settings are wrong on the Ethernet interface.
C. The qos pre-classify command should be removed from the tunnel interfaces.
D. the priority queue for the voice class is probably taking all the bandwidth
E. there are probably not enough interface buffers; they should be tuned.


Answer: B

Question 8

NBAR supports all of these with the exception of which one?

A. HTTP
B. IP multicast
C. TCP flows with dynamically assigned port numbers
D. non-UDP protocols


Answer: B

Explanation

NBAR classifies packets that are normally difficult to classify. For instance, some applications use dynamic port numbers. NBAR can look past the UDP and TCP header, and refer to the host name, URL, or MIME type in HTTP requests.

Question 9

Modified deficit round robin supports which of these functionalities?

A. priority queue
B. weighted fair queues
C. round-robin service of output queues
D. LLQ


Answer: A C

Question 10

A router is connected to an HDLC circuit via a T1 physical interface. The SLA for this link only allows for a sustained rate of 768 kb/s. Bursts are allowed for up to 30 seconds at up to line rate, with a window Tc of 125 ms.

What should the Be and Be setting be when using generic traffic shaping?

A. Be = 46320000 , Bc = 96000
B. Be = 768000 Bc = 32000
C. Be = 128000 Bc = 7680
D. Be = 0 Bc = 96000


Answer: A

Explanation

(Notice that the sustained rate is the CIR = 768kb/s)

From the formula Tc=Bc/CIR => Bc = Tc * CIR = 125ms * 768kb/s = 96000 bits
(In fact you should calculate with the default units, that is 0.125s * 768000b/s)
The T1 speed is 1.544 Mbps = 1544000bps. “Bursts are allowed for up to 30 seconds at up to line rate” ->Be = 1544000bps * 30 = 46320000 bits.

Terminologies: The term CIR refers to the traffic rate for a VC based on a business contract.
Tc
is a static time interval, set by the shaper.
Committed burst
(Bc) is the number of bits that can be sent in each Tc.
Be
is the excess burst size, in bits. This is the number of bits beyond Bc that can be sent after a period of inactivity.

Question 11

Which two of these parameters are used to determine a forwarding equivalence class? (Choose two)

A. IP prefix
B. Layer 2 circuit
C. RSVP request from CE for bandwidth reservation
D. BGP MED value


Answer: A B

Recommended reading:

+ QoS Frequently Asked Questions

Which of these correctly identifies a difference between the way BPDUs are handled by 802.1w and 802.1 D? A. 802.1 D bridges do not relay BPDUs.  B. 802.1 w bridges do not relay BPDUs.  C. 802.1 D bridges only relay BPDUs received from the root.  D. 802.1w bridges only relay BPDUs received from the root. Answer: C

Comments
  1. Sumesh
    February 7th, 2011

    Question 5 should have no ipcef in the beginning

  2. Andy
    February 8th, 2011

    Q10 – I have seen this exact config in a Cisco document and according to that the answer is A. But this messes with my head, using a token bucket logic bc tokens are added every time interval (125ms). So each tc interval that the link is running at line rate 96000 bc tokens are added and then removed. A further 96000 (be) tokens are also removed as it is running faster than bc. So the combination of adding 96000 bc tokens and removing bc + be (192,000) tokens means tokens are being removed at a rate of 96,000/125ms or 768K/s. Therefore I would have thought be was 768000 * 30 = 23040000. Though there is no possible answer like that. I do however find cisco’s documentation contradictory and without a traffic generator I can’t say how it would perform in practice.
    Anyone got any thoughts?

  3. chris
    February 23rd, 2011

    For a Tc=125ms and access rate = 1544000, the max rate during the Tc period can only be 193000. ( 1544000/8). So if we bursted to line rate for each Tc, we would burst to 1544000 for the 1 second period, then x 30 we get 46320000. The numbers for this questions are bogus, since Be tokens would not get filled in the bucket, since we never transmit below Bc, so no Be tokens would accumulate,

  4. Steve
    March 4th, 2011

    Question 5 incorrectly has the config snippet for Question 7.

  5. claudio
    April 22nd, 2011

    Q3; in the link http://www.cisco.com/en/US/docs/ios/qos/configuration/guide/polcing_shping_oview_ps6350_TSD_Products_Configuration_Guide_Chapter.html we have the information that CAR can not be configured on tunnel interface, so burst to low does not make sense

  6. bill
    April 27th, 2011

    q3
    If you go forward 2 or so sections in the document linked above it again states the restriction on tunnels. But this time it also has a note that GRE (which this one is by default) is supported. So nice cisco is not even consistent inside the same document.
    So mostly by the process of elimination it leaves the burst rate.

  7. Isaac
    May 23rd, 2011

    In Question 5, the class-map has the name “kazza2” while the policy-map has the class name “kazaa2” (note the typo), which is enough for the policy to fail 🙂 But this isn’t in the answers… 🙁

  8. Anon192168
    August 4th, 2011

    Q1: Valid PHBs are

    The Default PHB (Defined in RFC-2474)
    Class-Selector PHBs (Defined in RFC-2474)
    Expedited Forwarding PHB (Defined in RFC-2598)
    Assured Forwarding PHB (Defined in RFC-2597)

    Answer is B.
    Source:

    http://www.cisco.com/en/US/technologies/tk543/tk766/technologies_white_paper09186a00800a3e2f_ps6610_Products_White_Paper.html

  9. Anon192168
    August 4th, 2011

    Q6
    DiffServ Traffic Conditioner Block (TCB)
    • Classifier: Selects a packet in a traffic stream based on the content of some portion of the packet header.
    • Meter: Checks compliance to traffic parameters (ie: token bucket) and passes results to the marker and shaper/dropper to trigger action for in/out-of-profile packets.
    • Marker: Writes/rewrites the DSCP value
    • Shaper: Delays some packets to be compliant with the profile.

    That leaves only the querier and the dropper for answers, since the mechanism Shapes/Drops, dropper is also correct. The only one left out is a querier. Answer D

    Source:

    http://www.cisco.com/en/US/technologies/tk543/tk766/technologies_white_paper09186a00800a3e2f_ps6610_Products_White_Paper.html

  10. peak
    September 23rd, 2011

    can someone please explain the answer to question 2?

  11. anon1975
    September 29th, 2011

    @peak:Qn2. has an upside down config for CIR and Bc.
    For details on CIR and Bc, pl. refer to the “Explanation” section under Question 10.
    Qn2 also is an example in policy chaining. i.e., ‘tun-shap’ is referred from the interface and ‘tun-shap’ after applying shaping, is referring to policy-map ‘mark’ which forces ‘mark’ to be executed. so, shaper is now technically in the context of class ‘1234’.

    Now, with the formula CIR = Bc/Tc; and CIR and Bc are given (150Kbits and 300Kbits), we can solve for Tc = 300/150 = 2sec. Cisco allows Tc to be in the range of 10ms to 125 ms (or Tc value to be 0.01 to 0.125). If calculated Tc value is below or above this range, then the Tc is calibrated to this range. So, Tc in this case will be 125ms. So, every 1/8th of a second you will violate the CIR by a factor of 2 resulting in jittery traffic.

    Bc should ideally be configured as a fraction of CIR. For instance, if Tc is 0.1, a good value for Bc will be 1/10th of the CIR value. This will allow the system to have enough credit to send 1/10th of the CIR 10 times a second so you will not violate any SLA.

  12. Sarah
    October 1st, 2011

    Question 5 –

    Where is NBAR enabled in that configuration?

  13. jep
    December 27th, 2011

    Q2, just try to explain. cmiiw, more burst means more buffer, more buffer means longer latency (when there is congestion).

  14. CiscoGuyUSA
    January 16th, 2012

    RE: Q3 answer and the URL from comments above http://www.cisco.com/en/US/docs/ios/qos/configuration/guide/polcing_shping_oview_ps6350_TSD_Products_Configuration_Guide_Chapter.html

    I believe the discussion is over thinking the situation a bit. The ACL listed in the exhibit traps TCP traffic. The Cisco QoS Solutions Guide mentions explicitly that “testing of TCP traffic suggests that the chosen normal and extended burst values should be on the order of several seconds worth of traffic at the configured average rate.”

    The same link mentions that if burst values are too low, the effective rate will be lower than the configured CAR. I don’t think you need to worry about whether or not the tunnel interface is the issue here.

  15. shebeer
    March 24th, 2012

    i didnt get any single Q from above Q. Please wait for updated DUMPS

  16. Richies Right
    August 14th, 2012

    hey i checked quite a few of your pages out 🙂 who are you hosted with and how much is it annually?

  17. Subhashchander
    August 21st, 2012

    Hey team,Good evening to all and I hope this finds each of you doing well.I love this line cisco Qos is good in throey, but a pain in practice. please help After reading this line, I can agree that all the options avail / nerd knobs and detail functionality can be over whelming so with this said, for the lab, learn the CLI in the real world check smart port macros and see if they fit. 9 out of 10 times they will work just fine for whatever task is at hand I might suggest to configure this with smart ports and then see what config is automatically done for you. A lot of configs are done automatically so a good learning this is.To your earlier question, are you asking why the switch is not changing the L3 header to make the DSCP value to 24?Was the packet originally marked as 24? If so, why not just trust the DSCP? Hummm Perhaps it is not clear what you are trying to accomplish. If you have a phone attached, try and smart port and then check the 75 lines of config added, if you understand all that is being done, then you have a good grasp on L2 Qos. HTH,Andrew Lissitz

  18. Zakir Hussain
    December 30th, 2012

    Question 5:
    Answer is B, B. In class Kazaa2, you should configure a policer instead of a drop command.

    Question says to limit the traffic, and here in classmap it is dropping the Kazaa2 traffic and also there is no policing command in the class-map.

  19. kkw
    January 23rd, 2013

    What is Traffic Conditioner Block ?

  20. Feld
    April 10th, 2013

    Could someone pls explain why in Q4 the policer configuration does not implement the dual rate dual bucket? I see cir and pir, so there are 2 rates and the used model for this is dual bucket. RFC 2698 does not require anything else, then the usage of the dual bucket model – so what is the problem in the configuration?

  1. No trackbacks yet.
Add a Comment

CAPTCHA Image
Reload Image