Home > Physical Topology to Logical Topology

Physical Topology to Logical Topology

Knowing how to convert a physical topology into a logical topology that suits your demand is the first thing you have to do for your network to get up and run. In practical most of the networks are connected like this:

Physical_Topology.jpg

As you can see, all the routers are connected to two switches Sw1 & Sw2. If the network is large enough, Sw1 & Sw2 should belong to Core layer which requires high speed switching because they have to do hardest work in the network. They should be powerful to mitigate congestion if occurs. Redundancy is also very important in this layer by providing multiple paths so that when a link goes down packets can still travel to the destination. Sw3 & Sw4 requires less power to proceed traffic and they should belong to Distribution layer. The last layer, which is not presented here is the Access Layer where switches are connected directly to the end users/terminals. In fact Sw3 and Sw4 can be used in Access Layer if the network is not large.

So how can we convert a physical topology to a logical topology as shown below?

logical_topology.jpg

The answer is we will need to use VLAN, trunking, subinterfaces to achieve this. Let’s start with the first section of R1-R2-R6.

Note: You can download the Initial Config & Final Config of this lab here (open with Packet Tracer v5.3.3 or above): http://www.rstut.com/download/Physical_Topology_to_Logical_Topology.zip. We tested and all the configuration in this lab worked very well.

Section R1-R2-R6

We see all three routers R1, R2 & R6 use fa0/0 interfaces to connect to each other in this section and they all are connected to Sw1 in the physical topology so we only need to assign VLAN 126 to three corresponding ports on Sw1.

Physical_Topology_Section126.jpg

SW1:
interface range fa0/1 – 2, fa0/6
switchport access vlan 126

After typing above commands we will see a message like this:

% Access VLAN does not exist. Creating vlan 126

That means SW1 does not have Vlan 126 previously so it created one automatically.

Of course we will assign IP addresses on these routers and “no shut” them so that we can ping among them:

R1:
interface fa0/0
ip address 10.10.126.1 255.255.255.0
no shutdown
R2:
interface fa0/0
ip address 10.10.126.2 255.255.255.0
no shutdown
R6:
interface fa0/0
ip address 10.10.126.6 255.255.255.0
no shutdown

Now we can ping between them successfully:

R1#ping 10.10.126.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.126.2, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/1 ms

The first ping fails because whenever a router first sends a packet to a next-hop that has no entry in the ARP table, it has to send out an ARP Request first and wait for a reply. That waiting time causes the first packet to be dropped.

Section R2-R3

From the physical topology we learn that fa0/1 of R2 is connecting to Sw2 while fa0/0 of R3 is connecting to Sw1. Therefore if we want to connect these two interfaces we have to configure a trunking link between Sw1 & Sw2. In this part we only set fa0/23 of Sw1 & Sw2 as trunk links while turning off other switch-to-switch ports to make the explanation simple.

Physical_Topology_Section23.jpg

Sw1 & Sw2:

interface fa0/23
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown

Fa0/1 of R2 is connecting to SW2 so we configure Vlan 23 on this switch:

Sw2:
interface fa0/2
switchport access vlan 23
no shutdown

Configure IP address on fa0/1 of R2:

R2:
interface fa0/1
ip address 10.10.23.2 255.255.255.0
no shutdown

We see on R3, interface fa0/0 is connected to 2 different networks (one is R2-R3, the other is R3-R4-R5) so we have to use sub-interface on R3.

R3:
interface fa0/0
no shut
interface fa0/0.23
encapsulation dot1q 23
ip address 10.10.23.3 255.255.255.0

on Sw1 we have to declare the port connected to R3 as trunk as we are using subinterface on R3.

Sw1:
interface fa0/3
switchport trunk encapsulation dot1q
switchport mode trunk

Notice that SW1 still does not have Vlan 23 because we set trunking on fa0/3 so we have to manually createVlan 23 on SW1:

Sw1(config)#vlan 23

Note: If we don’t create Vlan 23 on Sw1, it will drop frames belong to Vlan 23 sent to it.

In the next part we will continue learning how to configure Section R3-R4-R5 & Section R6-R7-R8

Comments (50) Comments
Comment pages
1 2 528
  1. John
    October 10th, 2014

    good article. thanks

  2. Partha
    February 3rd, 2015

    Great

  3. Mohammad Mozamel
    February 27th, 2015

    Nice Practice

  4. CR
    March 25th, 2015

    How many lab questions do you get in the LAB exam?

  5. Anonymous
    March 25th, 2015

    Best material do study for CCIE LAB and Writen exam:

    http://cafecomredes.blogspot.com.br/2014/12/materiais-ccie-r-workbook-video-aulas.html

    🙂

  6. Anonymous
    May 18th, 2015

    Hey guys,

    Here you can download almost all Cisco Press Books:

    http://cafecomredes.blogspot.com.br/2015/05/colecao-cisco-press-download.html

    Bye

  7. soske
    July 11th, 2015

    shouldn’t we add vlan 345 on SW1 port 0/3?

  8. soske
    July 11th, 2015

    sorry what i meant is Sw1(config)#vlan345

  9. charles
    March 25th, 2016

    CCIE R&S Practice Labs ……………can someone make this in Packet Tracer…would be great

  10. Anonymous
    April 11th, 2016

    oh man! thanks you for the easy to understand explanation..U see i downloaded IOU-WEB VM v22 RSv5 UD for INE lab. I didn’t have the slightest idea how to go about in doing the lab especially the physical topology setup until and read this…thanks!

  11. Eric Manns
    May 27th, 2016

    Excellent material as always! Good read and refresher!

  12. Naveen
    March 2nd, 2017

    http://wikisend.com/download/726086/physical2logical-topoplogy.pkt

    Worked out succesfully !

  13. CCIE
    March 28th, 2017

    Hi Guys,

    Is anyone interested in discussing the CCIE R&S dumps.

    Skpe id – asha02839

  14. CCIE
    March 29th, 2017

    Hi Guys,
    Is anyone interested in discussing the CCIE R&S Lab dumps.
    Skpe id – asha02839

  15. CCIE
    March 30th, 2017

    Hi Guys,

    Is anyone interested in sharing the cost to buy ccie lab dumps.

    Skpe id – asha02839

  16. Mias
    March 31st, 2017

    Hello Guys
    Can anyone please assist me in setting up the the LAB .. if you need my e-mail: {email not allowed}

  17. Dumps
    April 6th, 2017

    Anyone interested in buying pssleader dumps for written and lab.
    Very special price with new updates as they come.
    contact Skpe id – asha02839

  18. new CCIE dumps
    April 7th, 2017

    new CCIE Dumps is comin
    http://cciers.spoto.net

  19. adarabea
    April 22nd, 2017

    Hello Dears,

    can anyone share CCIE labs for practices or can guide where I can find such files (config iou files, diagrams, answers and questions) ??

    BR,

  20. JP
    April 26th, 2017

    Hi guys, are this tut LAB practices any similar to the real exam? or are they actually part of the exam?

  21. Caden
    July 6th, 2017

    Thanks for your help. I passed my CCIE certification exam using https://www.lab4ccie.com/. I suggest the users to look the question answers and CCIE Data Center Lab very carefully. Some answers in the exams changed the sequence. You need read the questions very carefully.

  22. Torlo
    September 28th, 2017

    Hello,
    Someone reported that there is a NEW CONFIG in the CCIE Lab since the 25th of september 2017.

    Did someone else got it ? Or is it a fake news ?

    Thanks !

  23. Zorg
    January 20th, 2018

    Coool for latest dumps, but how to have the PDF for rs lab ?

  24. Lam
    March 3rd, 2018

    Anybody with passed Rs latest lab ?

  25. bee
    May 24th, 2018

    Hi Chris can we you create a lab study group. i also preparing for my lab soon.

  26. Ncice…
    June 2nd, 2018

    Really nice articles…enjoy…
    https://ipcisco.com/ccie/

  27. LostNode
    July 19th, 2018

    Hi, im preparing for CCIE R & S Lab exam.
    can anyone send me materials? its much appreciated.
    pack3tdr0p AT gmail DOT COM

    thank you in advance

  28. help me
    August 10th, 2018

    @NAN AThank you for sharing, I found that the information inside is really effective.

  29. Dinesh Kumar
    August 16th, 2018

    @NAN A

  30. JOG
    August 26th, 2018

    Any valid materials for CCIE lab exam?

  31. Sara
    August 28th, 2018

    asha02839

  32. Sara
    August 28th, 2018

    skype

  33. studi
    September 26th, 2018

    W ww.cci
    edumps.xyz?utm_source=bbs&utm_medium=bbs

    I just passed the CCIE200-101 exam last week. I bought the topic here. The topic is true and effective. I have practiced most of the exam questions, but you have to remember the answer. You can’t just remember it. The options, I have encountered several questions in it, the options for the correct answer have been changed.

  34. williams
    March 29th, 2019

    Looking for a exam material, but worried about finding a fake material site, I just passed the cisco exam, I used my actual experience to tell you that the material provided by url is effective and very stable, I use the material and I participate The exam questions at the exam were exactly the same, so I passed the exam very smoothly. I recommended this good exam material site to everyone and wish everyone a successful exam.

    w ww.cci edum ps.xyz/ccna_d umps.php?utm_so urce=bbs

  35. koko
    May 6th, 2019

    just passed the exam.
    thx passhot dot com

  36. CCIELab
    June 4th, 2019

    Recently I bought Cisco Expert-Level Traning for CCIE from Cisco Network store.
    Anyone interested to share the price, so I can give you the labs. There are 25 labs.

  37. SHP
    June 4th, 2019

    Hey CCIELab. I’m interested.

  38. Anonymous
    June 4th, 2019

    Hi SHP, you can send me email first to tuhink2019 at gmail dot com

  39. CCIELab
    June 4th, 2019

    Hi SHP, you can send me email first to tuhink2019 at gmail dot com

  40. Anonymous
    June 5th, 2019

    Hi SHP, please send me email to kunwar.binod56 at gmail dot com

  41. pass(No spaces)hot dot com
    June 6th, 2019

    share latest exam questions
    look my name

  42. Mike
    June 22nd, 2019

    Congratulations!!!

    Hi guys

    I went to the exam yesterday and it was successful!

    SECTION 1: Layer 2 Technologies

    Section-1.1: LAN Access
    The following requirements were pre-configured:
    ● VTP is turned off in all switches.
    ● All required VLAN including access-ports configuration in all relevant switches are
    provisioned.
    ● All required SVI interfaces in all relevant switches (including IP address and subnet
    mask) are provisioned.

    Configure the network in all sites as per the following requirements:
    ● Access-ports must immediately transition to the forwarding state upon link up, as long as they do not receive a BPDU. Use the minimal number of commands per switch to enable this feature.
    ● If an access-port receives a BPDU, it must automatically shutdown. Use the minimal number of commands per switch to enable this feature.
    ● Ports that were shutdown must attempt to automatically recover after 10 minutes.
    ● None of the switches may generate a TC (Topology Change) or a TCN (Topology Change Notification) when any of access ports goes down.

    Cisco will change in 2020, the guys who want to take the exam should hurry.

    So go to the exam as soon as possible!

    Good luck!

    P:pass
    H:hot
    I used the dump of the PH to pass the exam.
    at PH dooooooooot com

  43. CCIE19
    June 24th, 2019

    Dear Mike,
    Congratulations! I am preparing for CCIE RS Lab exam which I will write in August 2019,Please share your materials to me? elsh27gb @ gmail.com is my adders. thank you.

  44. kloo
    June 27th, 2019

    today i pass ccie rs 400-101 exam
    Share the test bank for my exam
    http:/**/c7.gg/fCXw8

  45. Lee
    July 3rd, 2019

    Hi guys download the RnS v5 WEB IOU

    “*ccielabcenter*com/free/iou-web-ccie-rs-h3-lab3/

  46. mok
    July 7th, 2019

    Thanks Lee , downloaded the iou from the above link.
    its working , also there are other free iou which i downloaded from website.
    great job

  47. Mega
    July 7th, 2019

    mega link for VM (CCIE R&Sv5 ALL Labs Loaded
    **mega.nz/#!7ixWCARQ!PfEe42IDKS9oY6JkhtwY3JXN7Z4hQ24vCAZPmyt-0Do

  48. Anonymous
    July 8th, 2019

    Downloaded vm from above link.
    keep on sharing free materials, helping a lot in preparation.

    lab 2.2 vm not available in the link.

    pls share vm fro lab 2.2 lab also

  49. Anonymous
    July 8th, 2019

    ##### CCIE R&S LAB 1 PDF #####

    https://mega.nz/#!b24yAALK!h9ejClIPTs-FSUCMC2g3_SRV4rHFyFg4H4mV4OnQa5w

  50. Samy
    July 9th, 2019

    Hey mate thanks for sharing the lab 1.1 WB.
    Kindly share the other wb also.

Comment pages
1 2 528
Add a Comment

CAPTCHA Image
Reload Image