Home > EIGRP OSPF Mutual Redistribution and Filter Lab

EIGRP OSPF Mutual Redistribution and Filter Lab

Topology:

Redistribute_Filter_Topology.jpg

Tasks:

1) Ensure R2, R3 can learned all the prefixes from EIGRP 10 as EIGRP External Route (D EX).

2) Guarantee if R2 or R3 dies R1 and R4 can still access services on R7. No default route is allowed in this lab.

You can download the initial configuration file here: http://www.rstut.com/download/route_map_distribute_list_redistribute_initial_config.zip.

The IOS I used to run this lab is c2691-adventerprisek9-mz.124-5a.bin but you can use others.

Solution

Initial Configuration

R1:
int s0/0
ip address 10.10.12.1 255.255.255.0no shutint s0/1ip address 10.10.14.1 255.255.255.0no shut

router ospf 1

net 10.10.12.1 0.0.0.0 area 0

net 10.10.14.1 0.0.0.0 area 0

R2:int s0/0ip addr 10.10.12.2 255.255.255.0no shutint s0/1

ip addr 10.10.23.2 255.255.255.0

no shut

int f0/1

ip addr 10.10.26.2 255.255.255.0

no shut

router ospf 1

net 10.10.23.2 0.0.0.0 area 0

net 10.10.12.2 0.0.0.0 area 0

router eigrp 300

net 10.10.26.0 0.0.0.255

no auto-summary

R3:int f0/1ip addr 10.10.35.3 255.255.255.0no shutint s0/0

ip addr 10.10.34.3 255.255.255.0

no shut

int s0/1

ip addr 10.10.23.3 255.255.255.0

no shut

router ospf 1

net 10.10.23.3 0.0.0.0 area 0

net 10.10.34.3 0.0.0.0 area 0

router eigrp 300

net 10.10.35.0 0.0.0.255

no auto-summary

R4:int s0/0ip addr 10.10.14.4 255.255.255.0no shutint s0/1

ip addr 10.10.34.4 255.255.255.0

no shut

router ospf 1

net 10.10.34.4 0.0.0.0 area 0

net 10.10.14.4 0.0.0.0 area 0

R5:int f0/0ip addr 10.10.56.5 255.255.255.0no shutint f0/1

ip addr 10.10.35.5 255.255.255.0

no shut

int f1/0

ip addr 10.10.57.5 255.255.255.0

no shut

router eigrp 10

net 10.10.57.0 0.0.0.255

no auto-summary

router eigrp 300

net 10.10.35.0 0.0.0.255

net 10.10.56.0 0.0.0.255

no auto-summary

R6:in f0/0ip addr 10.10.56.6 255.255.255.0no shutint f0/1

ip addr 10.10.26.6 255.255.255.0

no shut

router eigrp 300

net 10.10.56.0

net 10.10.26.0

no auto-summary

R7:int f0/0ip addr 10.10.57.7 255.255.255.0no shutrouter eigrp 10

net 10.0.0.0

no auto-summary

int lo0

ip addr 10.10.7.7 255.255.255.0

Note: On R5 and R7 if we do not write the wildcard masks in network statements under “router eigrp”, R5 will summarize to classful networks. For example on R5 if we only write the networks without wildcard masks like this:

R5:router eigrp 10net 10.10.57.0router eigrp 300net 10.10.56.0

net 10.10.35.0

Then “network 10.10.57.0”, “network 10.10.35.0” & “network 10.10.56.0” will be summarized to “network 10.0.0.0” and all three interfaces of R5 will run EIGRP AS 10 and 300 simultaneously:

Redistribute_Filter_R5_show_ip_eigrp_interfaces_no_wildcard_mask.jpg

By using wildcard masks R5 can identify which interfaces to run EIGRP 10 and 300:

Redistribute_Filter_R5_show_ip_eigrp_interfaces_use_wildcard_mask.jpg

1) Ensure R2, R3 can learned all the prefixes from EIGRP 10 as EIGRP External Route (D EX)

To make R2 & R3 learn prefixes from EIGRP 10 as External routes we have to redistribute EIGRP 10 into EIGRP 300. We will redistribute EIGRP 10 & 300 mutually so that they can communicate.

Redistribute between EIGRP AS 10 & 300:

R5:router eigrp 300redistribute eigrp 10router eigrp 10redistribute eigrp 300

Note: Redistribution from EIGRP to another EIGRP process does not need to declare metric but redistribution from other routing protocols to EIGRP does need to declare metric.

Now check the routing table of R2, R3 to see they have learned all prefixes from EIGRP AS 10 (including 10.10.7.0 & 10.10.57.0) as external routes.

Redistribute_Filter_R3_show_ip_route_use_wildcard_mask.jpg

Redistribute_Filter_R2_show_ip_route_EX.jpg

=> So now we completed the first task “On R2, R3 ensure that all prefixes learned from EIGRP 10 should be seen as EIGRP

External Route (D EX)”.

2) Guarantee if R2 or R3 dies R1 and R4 can still access services on R7. No default route is allowed in this lab.

Guarantee if R2 or R3 dies R1 and R4 can still access services on R7” -> to achieve this task we need to redistribute OSPF & EIGRP on both R2 and R3.

R2 & R3:router eigrp 300redistribute ospf 1default-metric 10000 100 255 1 1500 //When redistributing into EIGRP we need to set seed metricrouter ospf 1

redistribute eigrp 300 subnets

Just for your information, the question says “No default route is allowed in this lab” to prevent us from configuring one-way redistribution and using a default or static route in other part.

This is the end of this task but we want to discuss another question: will it cause a routing loop when doing bi-directional redistribution on two routers? Some people explain the redistribution loop like this:

OSPF_EIGRP_Mutual_Redistribution_loop.jpg

1. R7 advertises prefix 10.10.7.0/24 to R5 as internal EIGRP route (AD = 90)

2. R5 learns and advertises 10.10.7.0/24 as External EIGRP (D EX) route to R3 & R6 with an AD of 170.

3. R6 also advertises this prefix to R2 with the same AD of 170.

4. But R3 & R2 will advertise this prefix with an AD of 110 to each other because they see this route as External OSPF route (O E2).

The AD of 110 is better than the AD of 170 so R2 & R3 will consider they have just learned a new “better” route. Therefore R2 will set R3 as its next-hop to the prefix 10.10.7.0/24 and R3 will set R2 as its next-hop to the prefix 10.10.7.0/24 -> a routing loop occurs.

Is it true? Let’s check the routing tables of the prefix 10.10.7.0 to see what they have learned.

Redistribute_Filter_R1_show_ip_route_10.10.7.0.jpg
Redistribute_Filter_R2_show_ip_route_10.10.7.0.jpg
Redistribute_Filter_R3_show_ip_route_10.10.7.0.jpg
Redistribute_Filter_R4_show_ip_route_10.10.7.0.jpg
Redistribute_Filter_R5_show_ip_route_10.10.7.0.jpg
Redistribute_Filter_R6_show_ip_route_10.10.7.0.jpg

From the outputs above we can draw how the routing updates of 10.10.7.0 were sent out (represented by red arrows):

Redistribute_Filter_Routing_Updates_Path.jpg

In fact, the routing tables only shows the optimal (best) routing updates that have been accepted and updated into the routing tables. For example R3 also sends routing updates to R5 about prefix 10.10.7.0 but it is not the best path so it is not displayed in the routing table of R5. We can check with the “show ip eigrp 300 topology all-links” on R5:

Redistribute_Filter_R5_show_ip_eigrp_topology_all_links.jpg

-> We can see that R5 also receives advertisement of 10.10.7.0 from R3. So does R5 sends advertisement of 10.10.7.0 to R3? The output of “show ip eigrp 300 topology all-links” command on R3 reveals this:

Redistribute_Filter_Initial_R3_show_ip_eigrp_topology_all_links.jpg

-> R5 still advertises 10.10.7.0 to R3 but it is not updated in the routing table of R3 because of worse AD.

Another question is if R3 sends advertisement of 10.10.7.0 to R2. We can check that with the “show ip ospf database adv-router 10.10.35.3” command.

Redistribute_Filter_R2_show_ip_ospf_database_adv_router.jpg

-> R3 does not send advertisement of 10.10.7.0 to R2 because of split horizon rule (R3 has already received advertisement of that prefix from R2).

Note: “10.10.35.3” is the router-id of R3. You can check the router-id of a router by the “show ip ospf” command.

In this lab a routing loop would not occur between R2 & R3 because after R2 learned about prefix 10.10.7.0, it advertised this prefix to R3. Although R3 still learned about this prefix via redistribution (from R5) but the prefix 10.10.7.0 advertised from R2 has better AD so R3 accepted this path -> R3 sets R2 as its next-hop for this prefix.

In conclusion, mutual redistribution between EIGRP and OSPF on two or more routers does not create routing loop. In general, if the two running protocols have the concept of “internal” and “external” routes then routing loop will not occur. Routing protocol like RIP does not have these concept so it can create routing loop. But mutual redistribution on more than one routers may create suboptimal routing. In this lab to reach 10.10.7.0 R3 has to go through R2 -> R6 -> R5 which is not the best path. The suboptimal path is depended on which router advertises that prefix first.

You can download the final configuration file here: http://www.rstut.com/download/route_map_distribute_list_redistribute_final_config.zip.

Comments (50) Comments
Comment pages
1 2 513
  1. sub_ccie
    August 13th, 2014

    good post .does anyone passed v5 lab

  2. montreal
    September 2nd, 2014

    The network address between R5 and R7 is 10.10.57.0. Where is 10.10.7.0 coming from?

  3. Gonzalo
    September 28th, 2014

    I have got this question in ccie v4 lab …but more tricky … we have to route “optimal” and no AD modification was allowed. I believe the worst part of CCIE LAB is redistribution… always corner cases

  4. alberto
    February 23rd, 2015

    helloy guys anyone of you is using web iou?

  5. Anonymous
    March 25th, 2015

    Best material do study for CCIE LAB and Writen exam:

    http://cafecomredes.blogspot.com.br/2014/12/materiais-ccie-r-workbook-video-aulas.html

    🙂

  6. Theo
    July 7th, 2015

    I’m using Packet Tracer and a routing loop was created in my network when mutual redistribution was setup on R2 & R3. R2 and R3 both learned the route to 10.10.7.0 from each other as an External OSPF route with an AD of 110.

  7. confusing
    October 28th, 2015

    why not R3-R5-R2??

  8. confusing
    October 29th, 2015

    typo! why not through from R3-R5-R7?

  9. Beth
    January 4th, 2016

    Why I cannot see CCIE written exam share experience on this website any longer?

  10. buddy
    January 7th, 2016

    hi, nice topology.. to recall OSPF check below..
    http://ipcisco.com/single-area-ospf-configuration/

  11. BENJAMIN ODENIGBO
    July 18th, 2016

    I had good time practising this lab, its awesome.

  12. BENJAMIN ODENIGBO
    July 18th, 2016

    more labs pls

  13. David
    November 14th, 2016

    Hello gents,

    how to get those files 192Q or Spoto to pass the CCIE WRITTEN EXAM.

    Thank you

  14. Emile
    December 15th, 2016

    https://drive.google.com/drive/folders/0B-ob6L_QjGLpfnRCUEFYcEhWZUw3OGNQY2FUSkptUXBrZDVzeE8zdkJQUERtOUFINDBFQW8

  15. Ro
    January 11th, 2017

    Hello Guys,

    does anyone have CCIE r&s latest lab solutions, with gz files…i tried to download from above url but that url is not working properly..

    Please share the correct url

  16. Anonymous
    February 14th, 2017

    CCIE Sp lab and written
    100% pass
    £1200

  17. Anonymous
    February 14th, 2017

    CCIE Sp lab and written
    100% pass
    £1200
    CCIE LAB 1 And 2 £800

  18. Aelj
    March 26th, 2017

    Hello Future CCIE,

    someone have tried the SPOTO materials for LAB Preparation??

  19. Passed
    March 27th, 2017

    Passed today, used spoto + extras + new questions from below site. In this package everything is included that is required to pass exam. Cheapest Dumps provider ever.

    http://ccie-r-s.blogspot.com/

  20. David
    April 19th, 2017

    spoto updated latest dumps and it is accurate and valid.
    http://cciers.spoto.net/index.html#Dumps

  21. JP
    April 26th, 2017

    Hi guys, are this tut LAB practices any similar to the real exam? or are they actually part of the exam?

  22. Anonymous
    May 19th, 2017

    We provide high quality 300-101 Dumps PDF to get certification in Cisco CCNP . Each product is affordable, simple with fast download, and easy to understand.

    http://www.braindumpskey.com/exam/300-101.html

  23. Mac Man
    July 31st, 2017

    Hi Julia

    please can you share with me, I am face a predicament. I have to recertify and I have been having issues locating them. please please

    khudu121atgmail.com

  24. Human
    August 8th, 2017

    Hi, is this topology real exam topology?
    If so, from me, an EIGRP example too
    http://ipcisco.com/eigrp-configuration-with-packet-tracer/

  25. Aron
    November 9th, 2017

    EVE Comm Edition Reloaded version (updated to 2.0.84)
    with pre-loaded Cisco ISO file which was used in web iou
    now added 2 labs for practice more coming soon.
    L2-ADVENTERPRISEK9-M-15.1A.bin
    L3-ADVENTERPRISEK9-M-15.2.M1.bin
    L3-ADVENTERPRISEK9-M-15.4-1T.bin
    L3-ADVENTERPRISEK9-M-15.5-2T.bin
    Hidden Content
    https://mega.nz/#!kx0hTRCC!NePo9YbqnJicbryLEvS36v_E0GyVUgx82irXFFs6eqI

  26. Sameer
    April 4th, 2018

    IOU

    https://drive.google.com/file/d/1icm9PGcaDdGnJuAG5b1bI327W-Pyyqj1/view?usp=sharing

  27. ahmed2018
    June 16th, 2018

    hello guys can you please share with me the latest dumps?I am writing my exam very soon.

  28. 3days back
    June 18th, 2018

    Hello everyone,

    I am practicing for the LAB exam using eve-ng community edition.
    The images that I have don’t have most of the commands enabled
    does anyone have a valid ios images that works with dynamips?

    Kindly share.

  29. rrrr
    September 26th, 2018

    W ww.cci
    edumps.xyz?utm_source=bbs&utm_medium=bbs

    I just passed the CCIE200-101 exam last week. I bought the topic here. The topic is true and effective. I have practiced most of the exam questions, but you have to remember the answer. You can’t just remember it. The options, I have encountered several questions in it, the options for the correct answer have been changed.

  30. ertfgf
    October 10th, 2018

    There are a lot of testers and professional teachers to study and discuss together, as well as the latest test resources. Candidates who need the test can come and see. ht tp:
    //kks.me/aK2La

  31. Adeline
    December 4th, 2018

    Very useful.

  32. Adeline
    December 4th, 2018

    Very useful. Thanks for your sharing

  33. Molly
    December 4th, 2018

    S POTO offers many kinds of Cisco certification practice questions and answers.

  34. thing
    December 17th, 2018

    The 300-135 and 400-101 subjects are now stable, the latest update, and the people who passed the two days passed. Proshosts.com

  35. sdffg
    February 20th, 2019

    http s://docs.google.com/document/d/1KQZDbpoxq_BZ6bmUD7slcVovBEZBPC3fdTyvw4kqlvY/edit?usp=sharing
    Recommend an effective and useful place.

  36. koko
    May 6th, 2019

    just passed the exam.
    thx passhot dot com

  37. Billy
    June 22nd, 2019

    Congratulations!!!

    Hi guys

    I went to the exam yesterday and it was successful!

    Section 2: Layer 3 Technologies

    Section-2.1: OSPF in HQ
    Configure the headquarters network (BGP AS#65003) as per the following requirements:
    ● Both gateway routers of the headquarters network must always advertise a default
    route into the OSPF domain.
    ● All four devices produce the exact same output as shown below. Everything must
    match, except the “Dead Time” counters and line order.

    Section 2.2: OSPF in DC#1
    In order to speed up OSPF convergence in the datacenter#1 network, limit the number of IP prefixes that carried in OSPF LSAs that OSPF is pre-configured in all required devices in datacenter #1.
    Configure datacenter#1 network as the following requirements:
    ● All OSPF devices must exclude the IP prefixes of connected networks when
    advertising their type 1 router LSA, except for prefixes associated with the loopbacks
    or passive interfaces.
    ● All host loopbacks are the only OSPF Intra-area prefixes that may appear in any DC device’s routing table.
    ● Your solution must still apply if any new interface was added to the OSPF domain.
    ● Do not use any prefix-list or other explicit filter anywhere.
    ● Do not configure any interface as unnumbered.
    ● Do not remove any pre-configuration.

    Cisco will change in 2020, the guys who want to take the exam should hurry.

    So go to the exam as soon as possible!

    Good luck!

    P:pass
    H:hot
    I used the dump of the PH to pass the exam.
    at PH dooooooooot com

  38. Anonymous
    June 27th, 2019

    Check out the iou
    http:/–/ccielabcenter.c-o-m/free/iou-web-ccie-rs-h1-lab-lab1-1/

  39. che
    June 27th, 2019

    Check out the iou
    http://ccielabcenter.c-om/free/iou-web-ccie-rs-h1-lab-lab1-1/

  40. cain
    June 29th, 2019

    Hi guys download the RnS v5 IOU

    **ccielabcenter.c*om/free/iou-web-ccie-rs-h1-lab-lab1-1/
    **ccielabcenter.c*om/free/iou-web-ccie-rs-h1-lab-lab1-1/
    **ccielabcenter.c*om/free/iou-web-ccie-rs-h1-lab-lab1-1-2-2/

  41. Cain
    July 3rd, 2019

    Hi guys download the RnS v5 IOU

    http://ccielabcenter.com/free/iou-web-ccie-rs-h3-lab3/

  42. Anonymous
    July 3rd, 2019

    Thanks buddy for sharing it ?

  43. koris
    July 3rd, 2019

    @cain
    the link you have posted on June 29th, 2019 are not working

  44. Cain
    July 7th, 2019

    koris you can visit the mentioned website and download all the iou you required.
    all free materials

  45. Mega
    July 7th, 2019

    mega link for VM (CCIE R&Sv5 ALL Labs Loaded )

    https://mega.nz/#!7ixWCARQ!PfEe42IDKS9oY6JkhtwY3JXN7Z4hQ24vCAZPmyt-0Do

  46. Cain
    July 8th, 2019

    *****CCIE R&S LAB 1 PDF ******

    https://mega.nz/#!b24yAALK!h9ejClIPTs-FSUCMC2g3_SRV4rHFyFg4H4mV4OnQa5w

  47. Jui
    July 9th, 2019

    @cain , thanks for sharing , pls share the rest other wb also if you have.

  48. Bik
    July 11th, 2019

    Hie,

    anybody with lab 2 solution pls share

  49. mora
    July 14th, 2019

    hello . can i ask something regarding ccie lab exam .
    Is it allowed to use # show run ,” tab” and “?”

  50. @mora
    July 14th, 2019

    Yes : show run command is allowed in exam and also ? is allowed

Comment pages
1 2 513
Add a Comment

CAPTCHA Image
Reload Image