Home > Physical Topology to Logical Topology

Physical Topology to Logical Topology

Knowing how to convert a physical topology into a logical topology that suits your demand is the first thing you have to do for your network to get up and run. In practical most of the networks are connected like this:

Physical_Topology.jpg

As you can see, all the routers are connected to two switches Sw1 & Sw2. If the network is large enough, Sw1 & Sw2 should belong to Core layer which requires high speed switching because they have to do hardest work in the network. They should be powerful to mitigate congestion if occurs. Redundancy is also very important in this layer by providing multiple paths so that when a link goes down packets can still travel to the destination. Sw3 & Sw4 requires less power to proceed traffic and they should belong to Distribution layer. The last layer, which is not presented here is the Access Layer where switches are connected directly to the end users/terminals. In fact Sw3 and Sw4 can be used in Access Layer if the network is not large.

So how can we convert a physical topology to a logical topology as shown below?

logical_topology.jpg

The answer is we will need to use VLAN, trunking, subinterfaces to achieve this. Let’s start with the first section of R1-R2-R6.

Note: You can download the Initial Config & Final Config of this lab here (open with Packet Tracer v5.3.3 or above): http://www.rstut.com/download/Physical_Topology_to_Logical_Topology.zip. We tested and all the configuration in this lab worked very well.

Section R1-R2-R6

We see all three routers R1, R2 & R6 use fa0/0 interfaces to connect to each other in this section and they all are connected to Sw1 in the physical topology so we only need to assign VLAN 126 to three corresponding ports on Sw1.

Physical_Topology_Section126.jpg

SW1:
interface range fa0/1 – 2, fa0/6
switchport access vlan 126

After typing above commands we will see a message like this:

% Access VLAN does not exist. Creating vlan 126

That means SW1 does not have Vlan 126 previously so it created one automatically.

Of course we will assign IP addresses on these routers and “no shut” them so that we can ping among them:

R1:
interface fa0/0
ip address 10.10.126.1 255.255.255.0
no shutdown
R2:
interface fa0/0
ip address 10.10.126.2 255.255.255.0
no shutdown
R6:
interface fa0/0
ip address 10.10.126.6 255.255.255.0
no shutdown

Now we can ping between them successfully:

R1#ping 10.10.126.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.126.2, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/1 ms

The first ping fails because whenever a router first sends a packet to a next-hop that has no entry in the ARP table, it has to send out an ARP Request first and wait for a reply. That waiting time causes the first packet to be dropped.

Section R2-R3

From the physical topology we learn that fa0/1 of R2 is connecting to Sw2 while fa0/0 of R3 is connecting to Sw1. Therefore if we want to connect these two interfaces we have to configure a trunking link between Sw1 & Sw2. In this part we only set fa0/23 of Sw1 & Sw2 as trunk links while turning off other switch-to-switch ports to make the explanation simple.

Physical_Topology_Section23.jpg

Sw1 & Sw2:

interface fa0/23
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown

Fa0/1 of R2 is connecting to SW2 so we configure Vlan 23 on this switch:

Sw2:
interface fa0/2
switchport access vlan 23
no shutdown

Configure IP address on fa0/1 of R2:

R2:
interface fa0/1
ip address 10.10.23.2 255.255.255.0
no shutdown

We see on R3, interface fa0/0 is connected to 2 different networks (one is R2-R3, the other is R3-R4-R5) so we have to use sub-interface on R3.

R3:
interface fa0/0
no shut
interface fa0/0.23
encapsulation dot1q 23
ip address 10.10.23.3 255.255.255.0

on Sw1 we have to declare the port connected to R3 as trunk as we are using subinterface on R3.

Sw1:
interface fa0/3
switchport trunk encapsulation dot1q
switchport mode trunk

Notice that SW1 still does not have Vlan 23 because we set trunking on fa0/3 so we have to manually createVlan 23 on SW1:

Sw1(config)#vlan 23

Note: If we don’t create Vlan 23 on Sw1, it will drop frames belong to Vlan 23 sent to it.

In the next part we will continue learning how to configure Section R3-R4-R5 & Section R6-R7-R8

Comments (40) Comments
Comment pages
1 2 528
  1. Joe
    July 9th, 2019

    Can anybody pls share the R&S lab 2 solution.

  2. micky
    July 9th, 2019

    hi,

    anybody has valid dumps , pls share the links

  3. mok
    July 11th, 2019

    if anybody has cfg 3 – lab 3 solution pls share,
    thanks

  4. Joshu
    July 14th, 2019

    Pls share all lab files ,
    thanks

  5. Adan
    July 15th, 2019

    One guy reported there is a new lab4 H4

    if anybody going for an attempt and gets a new lab pls give feedback.

  6. @adan
    July 16th, 2019

    my exam is in this week.

    is this confirmed new lab arrived ?

  7. koris
    July 16th, 2019

    Nope … it is not yet confirmed ,

  8. Angelo
    July 16th, 2019

    I failed yesterday.
    i was not aware of the new lab and i got the new lab.
    money wasted …….time wasted ….
    .should attempt again or wait for new version
    dont know what to do now

  9. Anonymous
    July 16th, 2019

    R&S Lab WB
    https://mega.nz/#!63hRQAhI!hI8GJHGlWOa9omvUrcXlVBy5-84L7k9d-hciL_C7ESI

  10. @Angelo
    July 17th, 2019

    Did you received new lab with all new topology and all new questions ?

  11. Ady
    July 17th, 2019

    hey Angelo, can u pls share the details of new lab which u got in exam.

    my exam is very soon

  12. Hules
    July 17th, 2019

    Exam takers are getting lab4 in exam.
    be alert and updated

  13. Ammy
    July 17th, 2019

    pls check this update

    https://certcollection.org/forum/topic/327787-failed-12072019-cfg-new-lab-failed-ts-2-passed-diag-passed/page__pid__1297010__st__42#entry1297010

  14. Ima
    July 18th, 2019

    OMG !! this really seems to be a bad news
    only around 6 months left for the version to be changed and a new lab.
    may be cisco will be testing the new version features in this version new lab

  15. Nick
    July 19th, 2019

    My exam is scheduled in coming.
    M i going to get the new lab or any chances of getting old labs

  16. Nick
    July 21st, 2019

    OMG

    New lab is confirmed by an vendor

    Pass**ccie**exam**.com

  17. Lawrence
    July 21st, 2019

    Hey friends i spoken to pass-ccie-exam team and ccielabcenter team also with other vendors.
    Most of them have confirmed the arrival of new lab4 but they dont have workbook for new lab.

  18. Addy
    July 22nd, 2019

    @lawrence

    Do u have any proof of this confirmation of new lab4

  19. Cool
    July 22nd, 2019

    Hey Lawrence ,

    thanks for the info , my exam is in next week beginning,
    I think If pass-ccie-exam-.com has confirmed there is new lab than there should be no doubt of it as pass-ccie-exam-.com is a very old vendor in cert selling

  20. Bob
    July 22nd, 2019

    Hi friend.. i have also confirmed with both pass-ccie-exam-.com and ccielabcenter both have given confirmation of new lab…… Lab4

  21. Boby
    July 23rd, 2019

    when did you take the exam?

  22. John
    July 24th, 2019

    @Angelo

    sorry ! I can understand you. It is no easy.
    Please can you share your dumps ?
    nathaliemomo95 at yahoo.fr

    Or can somebody send me the dumps ? I just want to see how it is

  23. Alex
    July 24th, 2019

    Hey friends.

    Lab4 Lab topology is out :
    http://ccielabcenter.com/lab4h4-topology-released/

  24. @agnelo
    July 24th, 2019

    you said you got new lab.

    pls check the link share by alex ,
    was this the same topology which u got in exam of new lab ?

  25. Carry
    July 24th, 2019

    @alex thanks for sharing the info

    Have u purchased wb from ccielabcenter ?
    if yes hows it ?

  26. Carry
    July 27th, 2019

    ❤️❤️❤️❤️❤️ℂℂ?? ??? ??ℙ❤️❤️❤️❤️❤️❤️

    ⬅⬅⬅⬅⬅⬅⬅⬅⬅⬅⬅⬅ccielabtip.com/ccie-rsv5-discussion/⬅⬅⬅⬅⬅⬅⬅⬅⬅⬅⬅⬅

    GET DAILY UPDATES ON CCIE CERTIFICATION TRACKS
    COMMENT / DISCUS / SHARE

  27. Beran
    July 28th, 2019

    Pls anybody share lab4 rns deatils

  28. Brono
    July 30th, 2019

    Lab4 hit in brussels

    Pls check
    ccielabtip.com/ccie-rsv5-discussion/comment-page-3/#comment-343

    I hope its useful info

  29. CCIE RS Written
    August 1st, 2019

    Link to download CCIE RS written vaild in August 2019.

    http://iecollection.net/Forums/showthread.php?260-CCIE-RS-Written-Valid-in-August-2019&p=3172#post3172

  30. Bret
    August 2nd, 2019

    Lab4 and other labs are great discount sale going on

    ccielabtip.com/ccie-rsv5-discussion/comment-page-4/#comment-365

  31. Mop
    August 2nd, 2019

    I have passed my written exam 2 weeks back and planning for lab exam b4 the end of this version5. Is ccielabcenter workbooks good ? also this week they are having a sale of 50% off

  32. RENO
    August 8th, 2019

    There is no things called Lab4, these people are just trying to make money and confuse other people.

  33. SAM
    August 11th, 2019

    Hi all, if Lab 4 does not exist then what is the lab being provided to people taking it?

    Thanks

  34. RENO
    August 20th, 2019

    No Lab 4 provided to people, they claim to have received it just to confuse us and come with a fake lab.

  35. help
    September 10th, 2019

    Hallo guys,

    i need help , is there H4 Lab or not

  36. Markus
    September 19th, 2019

    failed today in brussel, i got new lab i didn’t see it before( not H4 ). the website buy old labs .don’t trust it .
    try to learn everything before you take the exam
    i will try again

    Good Luck

  37. kloo
    September 20th, 2019

    I passed the exam today many thanks to all

    Lab
    -EIGRP Stub Sim -IPv6 OSPF Virtual Link Sim -EIGRP Evaluation Sim

    D&D
    -NAT -mGRE/IPsec -Loose/Strict Mode
    https:*/**/**priv.sh/PWi4BF2

  38. Lasie
    September 23rd, 2019

    Hi guys, what is really the correct lab for the RS version5. Can we all just assist each other as Engineers?
    So if anyone has the Lab guide and the Topology, Please send to me on lasie at mail dot com
    Thank you very in advance.

  39. kloo123
    November 6th, 2019

    The most favorable price this year!
    Dumps for 70% off and Gifts for you.
    Free LAB, Free WRITTEN DUMPS.
    End this Black Friday Month.
    Never too late to Seize this opportunity.
    ciscodumps09 dot livejournal dot com/1509.html

  40. jose
    December 1st, 2019

    Anybody know where I can study/review ccda 200-310 exam

Comment pages
1 2 528
Add a Comment

CAPTCHA Image
Reload Image